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Compatibility

ColorWasher works under Windows 95, 98, NT, ME, 2000, XP. It supports the 8−bit RGB and 16−bit RGB color modes.

You need one of the following applications to use it:

Adobe Photoshop (Version 3 and higher)• 
Adobe Photoshop Elements• 
Adobe PhotoDeluxe• 
Adobe After Effects (Version 4.1 and higher, but not animatable)• 
Adobe Illustrator (Version 7 and higher)• 
Adobe ImageReady (Version 2 and higher)• 
ACDSystems PhotoCanvas (Version 2 and higher) (It is delivered with some versions of ACDSee)• 
CDH Image Explorer Pro (Version 4 and higher)• 
CiEBV Photoline 32 (Version 5 and higher)• 
Corel Draw (Version 6 and higher)• 
Corel PhotoPaint (Version 9 and higher)• 
Corel Bryce (Version 4 and higher)• 
Corel/Metacreations Painter (Version 6 and higher)• 
Deneba Canvas  (Version 6 and higher)• 
Discreet Combustion (Version 2and higher, but not animatable and preview is blueish)• 
Equilibrium DeBabelizer Pro (Version 5 and higher)• 
GIMP (Version 1.2.4 and higher, but preview doesn't work correctly, no color selection dialogs)• 
imageN (Freeware from www.pixoid.com)• 
IrfanView (Version 3.85 and higher, Freeware from www.irfanview.com)• 
Jasc Paintshop Pro (Version 4.12 and higher)• 
KnowledgeAdventure HyperStudio (Version 4.2 and higher, but no color selection dialogs)• 
Macromedia Freehand (Version 7 and higher)• 
Macromedia Fireworks (Version 2 and higher, but transparency isn't correctly displayed in the preview)• 
Mediachance PhotoBrush (But no color selection dialogs)• 
Megalux Ultimate Paint (Version 2 and higher)• 
Megalux Ultimate FX (Freeware from www.ultimatepaint.com/ufx/)• 
Microfrontier Digital Darkroom (Version 1.2 and higher)• 
Micrografx Picture Publisher (Version 8 and higher, but the preview zoom won't work)• 
Microsoft Image Composer (Version 1.5 and higher, but dragging the preview isn't possible)• 
Microsoft PhotoDraw 2000• 
Microsoft Picture It! Digital Image Pro (Version 7 and higher, but a 100% zoom may not work correctly and
Cancel sometimes produces a crash)

• 

Newave Chaos Fx: Twilight'76 (Version 1.2 and higher)• 
Picmaster (Version 1.25 and higher)• 
Plugin Commander Pro (Version 1.5 and higher)• 
QFX / QFX LE (Version 7 and higher)• 
Right Hemisphere Deep Paint• 
Satori PhotoXL (Version 2.29 and higher)• 
Serif PhotoPlus (Version 7 and higher)• 
Stoik ImageMan Pro (Version 5 and higher)• 
ThinkTank Ameri−Imager (Version 2 and higher)• 
Ulead Gif Animator (Version 4 and higher)• 
Ulead PhotoImpact (Version 4 and higher)• 
VCW Vicman's Photo Editor (Version 6.9 and higher, but preview dragging causes crash) (Freeware from
www.photo−editor.net)

• 

WebSuperGoo Achroma• 
Xara X

They haven't been tested, but should work with:

Ability PhotoPaint Studio♦ 
Adobe PageMaker (Version 6 and higher)♦ 
Adobe LiveMotion♦ 

• 
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BananaSoft TwistedPixel♦ 
CADlink SignLab (Version 5 and higher)♦ 
Corel/MetaCreations Painter 5.5♦ 
Corel/MetaCreations Art Dabbler♦ 
Corel Photo House (Version 2 and higher)♦ 
Corel Xara 2♦ 
DigisoftDirect ImagePro 2K1♦ 
Equilibrium DeBabelizer Pro (Version 4.5)♦ 
Fractal Design Detailer♦ 
Macromedia Director (Version 6 and higher)♦ 
MGI PhotoSuite (Version 4 or higher)♦ 
Newtek Lightwave (Version 5.6 or higher)♦ 
Newtek Inspire 3D♦ 
Newtek Aura (Version 2 and higher, but probably not animatable)♦ 
PM Imagic♦ 
Ulead PhotoExpress (Version 2 and higher)♦ 

They don't work with:

Adobe ImageStyler (Doesn't support filter plugins)♦ 
Adobe Premiere (Up to Version 5.1: Renders only black to image)♦ 
ArcSoft PhotoStudio 2000 (Up to Version 4.1: Does not support PhotoShop plugins)♦ 
Datatech ImageMan (crashes when dragging preview and crashes when applying effect)♦ 
FixFoto (Up to Version 2.74: Preview is segmented and final result contains an overlayed thumbnail)♦ 
discreet 3D Studio MAX (Up to Version 4.2: Background image isn't displayed; Color selection dialog
doesn't work; Renders a distorted red/green pattern)

♦ 

Macromedia xRes (Crashes on loading plugin)♦ 
Metacreations Painter 5 (Everything works except final rendering)♦ 
Microsoft Image Composer 1.0 (Does not recognize the plugin)♦ 
SPG ColorWorks: Web (Up to Version 4: Everything works except final rendering)♦ 
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Installation

Some graphics applications, e.g. Photoshop, and Photoshop Elements, demand that you install ColorWasher into their
Plugins folder. So you already have to choose the appropriate plugins folder during installation as it can be seen in the
screen shot below. Others applications, like Paint Shop Pro, Photo−Paint or PhotoImpact, let you install ColorWasher
wherever you like and let you select the ColorWasher location in their Preferences or Options dialog. Below are some
short instructions for installing ColorWasher in various applications.

Adobe Photoshop / Photoshop Elements / Illustrator / ImageReady

Make sure you installed the plugin(s) into the "Plugins" or "Plug−ins" sub folder inside the Photoshop,
Illustrator or ImageReady folder. We recommend that you create a sub folder called ColorWasher in that folder
and install it there. After restarting the application, you will find it/them in the Filter menu.

Adobe PhotoDeluxe

Make sure you installed the plugin(s) into the "Plugins" or "Plug−ins" sub folder inside the PhotoDeluxe folder.
We recommend that you create a sub folder called ColorWasher in that folder and install it there. After
restarting the application, you need to make PhotoDeluxe display all menu items if you didn't already do that.
To do that go to the Preferences sub menu of the File menu and choose the last item ("Extend Menu" or
something similar) on the sub menu. You will find the plugin(s) in the Effects menu.

Adobe PageMaker

Make sure you installed the plugin(s) into Rsrc/.../Plugins/Effects folder inside the PageMaker folder. We
recommend that you create a sub folder called ColorWasher in that folder and install it there. After restarting
PageMaker, you will find the plugin(s) in the Element> Image> Photoshop Effects menu.

CiEBV Photoline 32

Choose 'File options' or 'Extended' from the Options menu, click on the 'Plug In Path' tab and select the folder
where the plugin(s) is located. After pressing OK, the plugin(s) will appear at the bottom of the the Filter menu.
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Corel Photo−Paint

Press <Ctl + J> to display the Options dialog, select Plugins from the list box on the left, press the Add button
and choose the location of the plugin(s). The plugin(s) will appear in the Effects menu right after the Options
dialog disappeared.

Corel Photo House

Select Effects > Plug−in Effects > Add/Remove Plugin Effects. Press the Add button and select the folder
where the plugin(s) is located. After pressing OK, the plugin(s) will appear on the Effects > Plugin Effects
menu.

Deneba Canvas

Select "Preferences" from the File menu. In the Preferences dialog select the Paint tab. Press the Plug−ins
button and select the folder where the plugin(s) is located. After restarting Canvas, the plugin(s) will appear on
the Image > Filter sub menu.

imageN

Select "Plug−ins" from the Configure menu. In the appearing Plugins dialog press the Search button. After
imageN has searched all your drives for plugins (which can take some time), the plugin(s) will appear on the
plugin list, too. To apply a plugin, select it from the list and press the Test button.

IrfanView (Version 3.85 and higher)

Make sure that an image is displayed in IrfanView. Then select Image > Effects > Adobe 8BF filters. In the appearing
dialog press the "Add 8BF filters" button and choose the folder where you installed the plugin(s).They will now appear in
the list on the left. To run a plugin please double click on the appropriate item or select it and press the "Start selected
filter" button.

Jasc Paintshop Pro 4 − 6

Choose "Preferences" from the File menu, press the Plugin Filters tab and select the folder, where you installed
the plugin(s), in the Plugin Filters tab of the Preferences dialog. After pressing OK, the plugins will appear on
the Plugin Filters sub menu of the Image menu.

Jasc Paint Shop Pro 7

Choose Preferences > File Locations from the File menu, press the Plugin Filters tab and select the folder where
you installed the plugin(s). After pressing OK, the plugin(s) will appear in the Plugin Filters sub menu of the
Effects menu .

Jasc Paint Shop Pro 8 & 9

Choose Preferences > File Locations from the File menu, select the Plug−ins item from the list box, press the
Add button, press the Browse button and select the folder where you installed the plugin(s). After pressing two
times OK, the plugin(s) will appear in the Plugin Filters sub menu of the Effects menu .

Macromedia Freehand

Make sure you installed the plugin(s) into the English/Xtras sub folder inside the Freehand folder. We
recommend that you create a sub folder called ColorWasher in that folder and install it there. After restarting
Freehand, you will find the plugin(s) in the Xtras menu.

ColorWasher Manual 5



Macromedia Fireworks

Choose "Preferences" from the File menu and activate the Photoshop Plug−ins check box in the Folders section
of the Preferences dialog. Then select the folder, where you installed the plugin(s), by pressing the "..." or
Browse button. After restarting Fireworks the plugins will be displayed at the bottom of the Xtras menu.

Megalux Ultimate Paint

Choose "Preferences" from the Options menu, click on the Plugins tab and select the folder where the plugin(s)
is located. After pressing OK, the plugin(s) will appear in the Adobe sub menu of the Image menu.

Metacreations Painter / Fractal Design Detailer

Choose Preferences > Plugins... from the Edit menu and select the folder where the plugin(s) is located. After
restarting Painter/Detailer, the plugin(s) will appear on the Effects menu.

Microfrontier Color It!

Make sure you installed the plugin(s) into the "Plug−ins" sub folder inside the ColorIt! folder. We recommend
that you create a sub folder called ColorWasher in that folder and install it there. After restarting the application,
you will find them in the Filter menu.

Microsoft Photodraw 2000

Select Tools > Options and press the Plug−in tab. Press the Browse button and select the folder where the
plugin(s) is located. Finally press OK on the Options dialog. Choose Format > Effects > Plug−ins and select the
plugin in the combo box at the top of the Plug−ins dialog.

Micrografx Picture Publisher

Make sure you installed the plugin(s) into the "Plugins" sub folder inside the Picture Publisher folder. We
recommend that you create a sub folder called ColorWasher in that folder and install it there. After restarting
Picture Publisher you will find them in the Effects menu.

Right Hemisphere Deep Paint

Select File > Preferences > Directories and press the Browse button next to the Photoshop Plugins text box. In
the file dialog, select the folder where the plugin(s) is located and press OK. Then press OK on the Directories
dialog. After restarting Deep Paint, you will find the plugin(s) in the Filters menu.

SPG Colorworks: WEB

Choose "Preferences" from the File menu and select the folder, where you installed the plugin(s), at the bottom
of the Preferences dialog. After pressing OK the plugin(s) will be accessible from the Plugin Filter Selector
dialog which is available from the Effects menu.

Ulead Photo Impact

Choose "Preferences" from the File menu and select the folder, where you installed the plugin(s), in the Plugins
tab of the Preferences dialog. After restarting Photo Impact the plugin(s) will be displayed at the bottom of the
Effect menu.

Ulead Gif Animator

Choose "Preferences" from the File menu, click on the Plugin Filters tab and select the folder where the
plugin(s) is located. After restarting Gif Animator the plugin(s) will appear in the Filters menu.

ColorWasher Manual 6



Ulead PhotoExpress

Choose "Preferences" from the File menu and select the folder, where you installed the plugin(s), in the
Plug−Ins tab of the Preferences dialog. After restarting PhotoExpress the plugin(s) will be displayed in the
Photo menu.
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General Usage

Before using ColorWasher you have to start your preferred image editing application and open an image or photo. Please
note that ColorWasher only works on images in 8bit or 16bit RGB mode. If your image is grayscaled, has only 256 colors
or is a CMYK image, you have to convert it in your image application to RGB before you can start working on it with
ColorWasher.

To run Color Washer please open the menu that leads to the plugin filters (usually the "Filter", "Effects" or "Image −>
Plug−ins" menu) and choose "ColorWasher" from the " PhotoWiz" sub menu.

The Help Text Box

The Help feature has been built in to make it easier for new users to get started and makes it possible to use
ColorWasher without a glance in the manual. Other than that it can provide useful hints and assist you in the correction
process. If you move the mouse over a certain control, the text box will display some explanations and hints about that
control. Additionally it also tells you how to get started and if ColorWasher likes the current sample area.

After you know all about ColorWasher and mastered the sample area technique, you can deactivate these explanations
by deactivating the check box at the right bottom of the Help box. But we recommend that you keep it nevertheless
activated. It may remind you of something that you already forgot or missed reading.
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Changing the Window Size

Enlarging the ColorWasher window will allow you to display the image larger in the preview or a larger portion of the
image if you zoom in. However, doing that will also increase the time that ColorWasher needs to update the preview. If
you use an old and slow computer, it isn't recommended to enlarge the ColorWasher dialog. On the contrary you can also
make it smaller to make ColorWasher render the preview faster.

To resize the ColorWasher window and make the preview larger you have to move your cursor at the border of the
ColorWasher dialog. The cursor will then turn into a double arrow. Holding down the left mouse button and dragging the
mouse changes the size of the window. Double clicking the ColorWasher letters at the left side of the title bar will
maximize the window, double clicking them again will restore the old window size.

The Preview

On the left hand side of the dialog box is the preview box that shows you how the final effect will look like. When executing
ColorWasher it will always display the full image in the preview. This is also the recommended way to work on an image.
If you zoom into the image, only a part of the image is displayed in the preview. The image can then be moved by holding
down the right mouse button (or pressing the Alt key and holding down the left mouse button) and moving the mouse.
While it is moved, the original image is shown and after you release the left mouse button the preview is recalculated.

ColorWasher lets you draw a so−called sample area on the preview when you hold down the left mouse button and move
the mouse. Please don't confuse this sample area with an image selection as it is known from graphics applications. The
sample area may look like a selection marquee, but it is used to measure the color it surrounds and not for selecting a
certain part of the image. For more information, please read the Sample Area page.

If one of the Spit Views is activated, you can move the separation lines in the preview by holding down the ALT key and
dragging or you can select one of the split areas by holding down the Shift key and clicking on it. For more information,
please read the Split View page.

The Zoom Buttons and Zoom Check Box

At the right bottom of the preview box you can see a '+' and '−' button with a percentage label in between. These zoom
button let you adjust the size of the image in the preview box. 100% means that the original size of the image is displayed.

By default when starting ColorWasher, the zoom rate will be automatically set to make the image fit into the preview. If
you hold the Shift key when pressing one of zoom buttons, the zoom factor will be set to the highest (100%) or lowest
acceptable value (fitted zoom). If you hold the CTRL key when pressing one of the zoom buttons, the zoom factor will be
set to the highest (100%) or lowest possible value (6%). Some very old applications (e.g. Corel Photopaint 7 or Corel Xara
2) don't support preview zooming. In this case the + and − buttons are grayed out.

To jump from one preview zoom rate to another you can use the zoom combo box which is located between the two
zoom buttons. It also offers the option "Fit" which should be used most of the time.

Easy Mode

In Easy Mode only the most important controls and options will be accessible. This is helpful when you are just starting
with ColorWasher or want to do some quick corrections. For more information, please read the Easy Mode page.

Instant Preview

Activating the Instant Preview check box makes the preview update while you create a sample area, move the sample
area or move the Split View separation line(s). This immediate visual feedback helps you saving time when adjusting the
sample area or placing the separation line(s).
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IMPORTANT: If you have a slower computer (Pentium 500 or slower), you should set the zoom to "Fit" or even smaller.
That will speed up rendering the preview and will let you use the Instant Preview feature effectively.

Split View & Multiple

ColorWasher offers various split views for evaluating or correcting the image. For more information, please read the Split
View page.

The Neutral and B/W Buttons

Activating the Neutral button makes ColorWasher hide the areas of the image that are not or not nearly color−neutral. This
gives you a hint where you should draw a sample area. However, this feature doesn't work perfectly sometimes, so don't
trust it too much. For more information, please read the Sample Area page.

The B/W button displays the image in the preview grayscaled. This can be a help when correcting the Contrast, Exposure
or the Levels of the image. The B/W button can also be used to convert your image into B/W image. Various other options
of ColorWasher let you adjust the B/W look.

Sliders

Sliders can be used to select a certain value within a specific value range. To do that you can drag the slider knob with the
mouse (or keyboard), enter a numerical value in the white text box at the right of the slider bar, click somewhere on the
slider bar for large value steps or use the two arrow buttons for small value steps. Holding the Shift key while dragging
the slider knob, makes the preview update with every movement of the knob.

OK, Cancel and ?

Clicking on the OK button exits ColorWasher and applies the correction to the image. The current settings are saved and
restored when you use ColorWasher again. To make the visual cues (like the sample area, separation lines, Neutral mode
or B/W mode) visible in the processed image hold down the CTRL key while clicking on OK.

"Cancel" simply exits ColorWasher without changing the image. Depending on the application you are using, the current
settings will be lost immediately or kept as long as your image application is running. If you hold down the CTRL key while
clicking on Cancel, you will be prompted for Cloak Mode. In Cloak Mode the current settings will be applied to the image
without displaying the ColorWasher dialog. For more information, please read the Cloak Mode page.
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Step By Step Guide

Color Correcting Photos

The Quick Approach

1. Click on the Reset button to undo all previous changes.

2. Click on each of the Auto buttons at the top to get an impression of the color cast present in the
image.

3. Click again on the Auto button whose result you like best.

4. Click on OK to apply the correction.

The Effective Approach

1. Click on the Reset button to Undo all previous changes.

2. Click and drag on the preview to select a relatively large area that was white or neutral gray in the
original scene. If you don't know what to select, activate the Neutral button. Then select one of the areas
that is still checkered out and deactivate the Neutral button again. If your computer is too slow or old,
you can also activate Instant Preview check box to get immediate feedback about the correction.

3. If the created sample area isn't placed perfectly, hold down the CTRL key and drag it. If there is no
suitable sample area available in the image, please use the quick approach above or manual approach
below.

The Manual Approach

This approach isn't very easy and needs quite some time. Please use the quick and effective approach
before continuing with this one.

1. Click on the Reset button to undo all previous changes.
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2. Click on the preview and drag to select an area that was white or neutral gray in the original scene. If
there isn't such an area or if you want to enhance the color of a certain object (e.g. grass, sky, leaves),
please create a sample area over that object.

3. Switch to the Color tab sheet. The Source color box is automatically selected now. So if you want to
adjust the sampled color, please use the three sliders below the two color boxes. Select the HSL item
from the Color Model combo box for adjusting hue, saturation and lightness.

4. If you didn't select a gray or white area on the review, but a certain color that you want to change,
please select the Target color box by clicking on it. You can click again on it for displaying a color dialog,
you can use the three sliders below or click on the color picker icon to adjust the target color. Select the
HSL item from the Color Model combo box if you want to adjust hue, saturation and lightness. If you
don't want to change the brightness or lightness of the image, please make sure that the Balance
button, which is located between the two color boxes, is activated.

5. Adjust the Source and/or Target color boxes until you are satisfied with the result.

Correcting Contrast and Exposure

1. If you don't want to keep the current color correction, click on the Reset button. Otherwise don't click
on it.

2. Set the Auto Contrast to Normal and the Exposure Fix combo boxes to Autodetect if they aren't
already set to it.

3. If you don't like the result, try the other options from the Auto Contrast and Exposure Fix combo
boxes. Please note that the Exposure Fix result depends on the Auto Contrast setting. So the same
Exposure Fix setting may produce a different effect when the Auto Contrast setting is changed.

4. If your preferred effect is somewhere in−between the options of the Auto Contrast or Exposure Fix
combo box, please use the slider below the appropriate combo box to adjust the effect.

5. Additionally you can use the Highlights and Shadows sliders from the Extras tab sheet if you are not
satisfied. If there are too bright areas in the image, please decrease the value of the Highlights slider. If
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there are too many shadows that you would like to see more detailed, please increase the value of the
Shadows slider. You can additionally adjust with the H−Contrast and S−Contrast sliders.

6. Try the Sat Fix check box (and maybe also the Boost check box) and see if they produce better
results.

Correcting the Exposure Visually

1. If you don't want to keep the current color correction, click on the Reset button. Otherwise don't click
on it.

2. Select Exposure Stripes from the Split View combo box below the preview.

3. You will now see six areas to which a different exposure is applied. The exposure values of these split
view stripes range from −1.00 to +1.50.

4. If you want to see the effect of one of the exposure areas on a different part of the image, move the
mouse cursor over that area, hold down the ALT key and drag it to the area of the image where you
would like to see it applied. As a result the stripes will be shifted. To move the exposure area
interactively, activate the Instant Preview check box. To see the same image content in all six stripes,
please activate the Multiple check box.

5. After you decided which exposure stripe looks best, hold down the Shift key and click on it. As a result
the exposure stripes will vanish, the Exposure slider will be set to the selected value and the preview will
be updated with the newly selected exposure.

Correcting A Color Cast and Producing Color Effects at the Same Time

1. Click on the Reset button to undo all previous changes.

2. Click and drag on the preview to select a relatively large area that was white or neutral gray in the
original scene. If you don't know what to select, activate the Neutral button. Then select one of the areas
that is still checkered out and deactivate the Neutral button again. If your computer is too slow or old,
you can also activate Instant Preview check box to get immediate feedback about the correction.

3. If the created sample area isn't placed perfectly, hold down the CTRL key and drag it. If there is no
suitable sample area available in the image, please try one of the Auto buttons at the top.

4. The sampled color is automatically placed in the Source color box when creating a sample area or
when using an Auto button. Switch to the Color tab sheet to see it.
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5. To create a color effect click on the Target color box to select it. You can click again on it for
displaying a color dialog, you can use the three sliders below or click on the color picker icon to adjust
the target color. Select the HSL item from the Color Model combo box if you want to adjust hue,
saturation and lightness. If you don't want to change the brightness or lightness of the image, please
make sure that the Balance button, which is located between the two color boxes, is activated.

6. Adjust the Target color box until you are satisfied with the result.

Producing Artistic Color Effects

The Quick Approach

1. Click on the Reset button to undo all previous changes.

2. Select Hue Stripes or Hue Grid from the Split View combo box below the preview. You will now see
stripes or boxes to which a different color is applied.

3. If you want to see the effect of one of the areas on a different part of the image, move the mouse
cursor over that area, hold down the ALT key and drag it to the area of the image where you would like
to see it applied. As a result the stripes or boxes will be shifted. To move the areas interactively, activate
the Instant Preview check box. To see the same image content in all areas, please activate the Multiple
check box.

4. After you decided which area looks best to you, hold down the Shift key and click on it. As a result the
Split View will be deactivated and the preview will be updated with the newly color effect.

The Manual Approach

1. Click on the Reset button to undo all previous changes.

2. Switch to the Color tab sheet and click on the Target color box to select it.

3. Click again on it for selecting a color from a color dialog. You can also use the three sliders below to
change the colors. Select a different item (e.g. HSL) from the Color Model combo box if the RGB sliders
aren't sufficient. If you don't want to change the brightness or lightness of the image, please make sure
that the Balance button, which is located between the two color boxes, is activated.

4. Adjust the Target color box until you are satisfied with the color effect.

Producing B/W effects

The Quick Approach

1. Click on the Reset button to undo all previous changes.

2. Switch to the Extras tab sheet and move the saturation slider to the outer left position.

3. Choose one of the items from the Sat. Method combo box to produce a special B/W variation.
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4. Use the Contrast, Exposure and HS features to adjust the image as you like.

The Effective Approach

1. Click on the Reset button to undo all previous changes.

2. If you already opened a black &white or grayscaled image in ColorWasher, please continue with step
6.

2. Click on the B/W button below the preview.

3. Switch to the Color tab sheet and use the two color boxes, the Color Model combo box and the three
sliders to determine how much dominance each color component gets in the grayscaled image.

4. If you like it really complex, you can apply an additional B/W filter. However, this additional filter can
easily introduce artifacts, so be careful. To do it anyway please switch to the Extras tab sheet, choose
one of the items from the Sat. Method combo box and move the saturation slider to a preferred value.

5. Use the Contrast, Exposure and HS features to adjust the image as you like.

Colorizing B/W images

1. Click on the Reset button to undo all previous changes.

2. Switch to the Color tab sheet and click on the Target color box to select it.

3. Click again on it for selecting a color from a color dialog. You can also use the three sliders below to
change the colors. Select the a different item (e.g. HSL) from the Color Model combo box if the RGB
slider aren't sufficient. If you don't want to change the brightness or lightness of the image, please make
sure that the Balance button, which is located between the two color boxes, is activated.
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Tips for Tough Cases

ColorWasher lets you correct most digital or scanned photos perfectly within seconds. You only need to keep the default
settings and use the auto buttons or the sample area feature. However, if you want to process a very old and faded photo,
a totally trashed digital shot or a special image type like a drawing or artificial graphic, you may need to do some extra
tweaking and experimenting in ColorWasher. While you would need several minutes or up to a few hours to tweak a photo
perfectly in Photoshop or other tools, you will only need one or two minutes in ColorWasher if you read the tips below.

Tip 1 − Try the Sample Area

The Auto buttons of ColorWasher achieve a good color correction on little or medium difficult color casts. For very difficult
cases you should consider creating a sample area on the preview. Please experiment with the placement of the sample
area to get the best effect. Sometimes it can help to move the sample are a little away from a white or gray image area. It
may also help to sample unusual image areas. For very tough photos you should consider creating a second sample area
in different part of the image. That can give the result a more balanced look.

Tip 2 − Try different Cast Type options

Although the Autodetect item of the Cast Removal combo will work in many cases, it may be less effective for very special
cases. So please try every cast type option and use the one that produces the best result.

Tip 3 − Use the Adjust Cast and Highlights/Shadows Sliders

The Adjust Cast slider basically adjusts the saturation of the color correction. So it can help to set a negative or positive
value for the Adjust Cast slider. Especially when you are correcting close−up shots which often don't offer reference
colors for the Auto buttons or for the sample area. You can further fine tune the color correction by using the Highlights
and Shadows sliders below the Adjust Cast slider to change the intensity and direction of the color correction in these
image areas.

Tip 4− Play with the Color Controls

If none of the of the above mentioned tips help, you will have to trust you own judgment of the right colors. Selecting HSL
from the Color Models combo gives you the best options for doing a manual color correction. Try the Hue and Saturation
slider for different colors and color variations. Hold down the Shift key while dragging the sliders to get an instant
impression of the colors. Please make sure that the Balance icon is activated, otherwise you might change the lightness
of the image. Additionally you can also use the Color dialogs, color picker or the Split View options to make your image
look as you prefer it.

Tip 5 − Tweak Auto Contrast

Screen shots and graphics with only a few colors may get burned by the activated Auto Contrast. In some rare cases it
might also be a good idea to switch off or reduce the Auto Contrast. Activating the Boost check box can produce better
results with difficult images.
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Tip 6 − Different Exposures

Sometimes you might want to lighten a part of the image more than the "Autodetect" or "Enhance Shadows" option of
Exposure Fix does it. Some images profit from a "Balance Midtones" setting. However, if you notice that some other areas
of the image get too bright, you should consider decreasing the value of the Highlights or Exposure slider or applying
ColorWasher to a selection of that image area only. The Sensitivity slider lets you adjust the contrast of the brightness
change which can be a big help.

Tip 7− Saturated or Not Saturated?

Try activating the 'Sat Fix' check box and see if the result is better. Usually this feature reduces the saturation a bit.
Sometimes it seems to desaturates the photo too much, but sometimes it helps to improve the performed color correction.
Often using the Saturation slider is more flexible, but produces slightly different results.

Tip 8 − Highlights or Shadows (HS) Fixing

Often it can help to use the HS sliders to make the photo look better, because some areas of a photos are more exposed
as they should be while other are perfectly exposed. If the HS adjustment might give some image areas a grayish or
oversaturated look, try the H−Contrast and S−Contrast sliders to adjust it.

Tip 9 − Correct Image Areas Independently If Necessary

If there were different intensive light sources in an image, you sometimes don't have a choice but to create an image
selections for different areas of the image in your image application. Please don't forget to feather these selections to
avoid had transitions. Applying ColorWasher to these image areas independently, ensures that it can work perfectly on
removing the individual casts.

Tip 10 − Sleep On it and Try Again the Next Day

Sometimes when you are very enthusiastic or in a hurry to correct a photo, you might do a correction that isn't that
brilliant. If you have the time, it sometimes helps to leave a photo alone and to try correcting it again the next day. You
might find that you missed something the other day, added a too strong antagonistic color cast or didn't adjust the
exposure perfectly.
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Monitor Calibration

Calibrating your monitor is quite important if you want to do serious photo correction on your computer. If you have
wondered why your photos come too bright or dark out of the printer or from your photo service after you corrected them,
you should consider calibrating your monitor. A good calibrated monitor isn't absolutely necessary for using ColorWasher
if you stick to ColorWasher's default settings and don't use the its manual controls. But it is really recommended to so.

Calibrating a monitor can be a longer lasting process. Usually you think that you calibrated the monitor correctly after
going through some complex procedures. But some hours or days later you might find it unsatisfactory, because you
adapted to its color temperature and recognize a color cast that you didn't see before, or your eye may begin to burn,
because the monitor's display is too bright. Then it is time to readjust or recalibrate the monitor or your system gamma.
Don't be surprised if you need to do that more than just two times :−).

Monitor Brightness &Contrast

You should set brightness and contrast with your monitor's knobs to values that don't strain your eyes too much. Here are
some recommended values which vary between individual and display device:

Recommended
Monitor Values

CRT
Monitor

TFT Monitor
with RGB Input

TFT Monitor
with DVI−Input

Contrast 100% 30 − 50% 10 − 30%

Brightness 10 − 50% 10 − 75% 10 − 50%

The Monitor Brightness and Monitor Contrast also shouldn't be set too extremely, otherwise the colors might be displayed
a bit washed out or too saturated. But above all they are not so important, because calibrating your system for the optimal
gamma doesn't depend on the monitor's brightness and contrast. However, you still use one of the white and black
patterns from the URLs below when adjusting your monitor's brightness and contrast.

Please note: If you readjust the brightness or contrast of your monitor later, you should recalibrate the system gamma.

Links:

The following URL describes how to accurately adjust the brightness and contrast on your CRT monitor.
There are other calibration resources on the same site, too.
http://www.aim−dtp.net/aim/calibration/blackpoint/crt_brightness_and_contrast.htm

Here are some calibration patterns and instructions:
http://desktoppub.about.com/library/weekly/aa070102a.htm
http://www.mindspring.com/~woharris/cal.htm
http://www.dramainnature.com/monitor_calibration.htm
http://www.lunnfabrics.com/monitor.htm

Monitor Color Temperature or RGB Values

Several monitors let you set their color temperature. Often you are offered 6500 Kelvin or 9300 Kelvin. At 9300 Kelvin
your monitor already displays the colors too blueish, while at 6500 Kelvin there will be a bit too much yellow present. If
you don't have an option in between or can't set a custom value, please use 6500 Kelvin.

I you have the option to set your monitor's RGB balance, then try that. Make sure that you have an image with a lot of
gray or white tones displayed or simply an application with a gray colored background (but not the yellowish gray of
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Windows 2000 and XP!). Firstly set all R, G and B values to a similar value, e.g. 50%. If you see a certain color cast on
the gray or white image, use the R,G and B knobs to remove it.

Please note: If you readjust the brightness or contrast of your monitor later, you should recalibrate the system gamma.

Calibration with a Print

A crude but some times effective method for adjusting the brightness of your monitor is to print a photo with your printer or
to order a print from your preferred photo service and to use that print for adjusting the brightness setting of the monitor.
Makes sure that there is a similar light as you usually have when working on the computer.

Gamma

Some applications like Paint Shop Pro offer a "Monitor Gamma" option. First of all, the term is incorrect and should be
called "Application Gamma" and secondly these options only display the images at the selected gamma within that
application. Using such an application−dependant gamma makes no sense and leads to confusion, because when you
display the same image in a different application, e.g. you browser, it might look totally different.

What you should use is a system−wide gamma adjustment. If your monitor already includes an ICC profile on an
CD−ROM, you should install it. You can also manually add it under Start > Settings > Control Panel > Display > Settings >
Advanced > Color Management. After doing that you may need to change the brightness setting of your monitor again as
described above.

Otherwise you can also the gamma feature that the drivers of some video cards offer. If you only installed the standard
Windows drivers of your video card, please install the ones from the video card's manufacturer. That might give you such
a feature. However, the gamma feature should also contain interlaced patterns for adjusting the optimum gamma. Various
patterns are available on the Internet if you miss one. See below. To adjust the gamma you usually have to close your
eyes a bit or move away from the monitor to see the pattern(s) a bit blurred. I know it can be tiring to keep your eye lid that
way or stretch yourself to still reach the mouse, but that's the price :−).

As an alternative to your video card's gamma feature you can also use an application to create a ICM profile for your
monitor. A good tool for this purpose is the Adobe Gamma control panel which is installed with Adobe Photoshop. If you
don't own Adobe Photoshop, you can try to download a demo version of it and install it. Adobe Gamma contains a wizard
which leads you thought the calibration process and automatically activates the generated ICM profile.

Please notice: If you exchange your video card or monitor later, you should recalibrate the system gamma.

Links:

How to use Adobe Gamma:
http://www.ephotozine.com/techniques/viewtechnique.cfm/recid/12

Some gamma patterns and explanations can be found at the following address. But please ignore the
comments about setting your system default system gamma to 1.8 or 2.0. That is not necessary to get a
good calibrated monitor.
http://www.photoscientia.co.uk/Gamma.htm

Here are some more gamma calibration patterns:
http://epaperpress.com/monitorcal/
http://desktoppub.about.com/library/weekly/aa070102a.htm

Special Calibration Devices

The must reliable way to calibrate your monitor is to use a hardware device that is placed on the monitor for measuring
colors and brightness. This approach is especially recommended for TFT monitors as they have more problems with
displaying color correctly than CRT monitors. For example the Spyder callibration device from Colorvision is already
available for $150.
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Links:

Colorvision Spyder:
http://www.colorvision.com

Printer Callibration

If you use a professional photo service, you don't need to worry much about printer callibration. But if you want to print
your photos with your own printer, this can be an issue. Printer drivers are usually already calibrated for the inks and
papers of the printer manufacturer. If you use other inks and papers, you may need to calibrate your printer. There are
some companies that sell printer profiles, so that you don't need to calibrate your printer yourself. But as these profiles are
only calibrated for certain cases, you may have no luck when using them. For an accurate printer calibration you will also
need a hardware device that measure the colors and brightness of a print.
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Key Shortcuts

ColorWasher lets you use a few key shortcuts for performing certain tasks. Professional computer usually prefer to use
key shortcuts as they help to achieve some tasks much faster. The shortcuts are indicated by an underlined letter in the
button label. Here is a list of all shortcuts that can be used in ColorWasher:

Key Shortcut Explanation

ALT and 1 Triggers the Auto1 button

ALT and 2 Triggers the Auto2 button

ALT and 3 Triggers the Auto3 button

ALT and 4 Triggers the Auto4 button

ALT and E Activates or deactivates Easy Mode

ALT and F Activates or deactivates the Sat Fix check box

ALT and M Activates or deactivates the Multiple check box

ALT and N Activates or deactivates the Neutral Mode

ALT and O Displays a file dialog for opening a color preset

ALT and R Resets some controls to their default values

ALT and S Displays a file dialog for saving a color preset

ALT and U Undoes the latest action and returns to the previous settings

ALT and W Activates or deactivates the B/W Mode

ALT and + Increases the preview zoom ratio

ALT and − Decreases the preview zoom ratio

ALT and ? Displays the manual

ALT and B
(When the mouse is placed over the preview) Displays an page
with photos of the ColorWasher beta testers.

If the input focus is not resting on a combo box, slider box, the B/W or Neutral button, you have can press the mentioned
keys without the ALT key. But to avoid confusion, please always hold down the ALT key for these key shortcuts.
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Easy Mode

When you run ColorWasher for the first time, you are asked if you want to start with Easy Mode. If you don't have very
much knowledge about photo correction, you should follow this invitation. But even as a pro you will sometimes prefer to
work in Easy Mode if you want to achieve results very quickly and don't need or have the time to tweak your photos.

In Easy Mode you are only presented with automatic and semi−automatic features. The manual controls are hidden as it
takes more time and knowledge to adjust them or use them correctly. That doesn't mean that you aren't able to achieve
such good results as in Advanced mode. For most images working in Easy Mode is sufficient. Only difficult images may
require to deactivate Easy Mode.

However, you can't do artistic effects that good in Easy Mode. Artistic color effects are easier to produce with the manual
controls in Advanced mode.

Creating a Sample Area

Left click on the preview box and drag to create a sample area marquee. The sample area should be created above an
area of the image that was neutral gray or white in the original scene. Activate the Neutral button to get an impression of
which area to sample. The colors will be automatically corrected with what is measured from the sample area.

For detailed information about this feature, please read the Sample Area page.
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Reset

Clicking on the Reset button sets most controls to their default values. As a result there will be no color correction applied
to the image. The Auto Contrast and Exposure Fix are set to their default values.

Auto 1 − 3

Clicking on one of the Auto buttons performs an automatic color correction. Each of them works best on certain image
types. So please try them all four and keep the correction that fits best.

For detailed information about this feature, please read the Auto Buttons page.

Cast Type

The Cast Type combo box lets you choose between seven different items. Keep it set to Autodetect if you don't want to
mingle with the different choices. That will work perfectly for most images.

For detailed information about this feature, please read the Cast Types page.

Auto Contrast

The Auto Contrast combo box offers you different choices for automatically adjusting the contrast of the image. Keep it at
Normal to achieve a good result for many images. Only if you like a more intense contrast, set it to Strong or Intense.
Avoid the Extreme setting as it often burns the image. Use the Boost option if the contrast is still low.

For detailed information about this feature, please read the Auto Contrast page.

Exposure Fix

The Exposure Fix combo box offers various options for adjusting the brightness. Please keep Exposure Fix set to
Autodetect as this produces the best results in many cases without making the image too bright or dark. The Balance
Midtones option may work fine, too.

For detailed information about this feature, please read the Exposure Fix page.
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Reset, Undo &Presets

Reset

When you want to undo the current correction settings, you can click on the Reset button. This is helpful if you want to
undo a correction or when you start with a new image. The behavior of the Reset button can be defined by the On Reset
combo box on the Prefs tab sheet. For more information, please read the Prefs Tab page.

When you use the manual controls, the sample area marquee disappears, because it doesn't correspond with the
selected settings any more. Holding the CTRL key and clicking on Reset activates the sample area marquee again and
makes it visible. Any manual adjustments to the Source and Target color boxes will be lost.

Right clicking on the Reset button will display a context menu with various options. The first five options correspond to the
options of the On Reset combo box of the Prefs tab: "Default Settings"deactivates a lot of other controls, but activates the
default setting for the Auto Contrast and Exposure Fix options."Original Image" deactivates all corrections and displays
the uncorrected image. "Preview Settings" loads the settings that were used for correcting the previous image. "Own
Defaults" will automatically open the preset file that you have chosen when selecting the "Own Default" in the Prefs tab.
"Logged Settings" will open a preset that was automatically saved when you corrected the same image the last time. If
ColorWasher can't find such settings nothing will happen.

The four "Reset ... Tab" options will reset only the controls of the appropriate tab sheet. The same effect can be achieved
by shift clicking the appropriate tab button. "Restore Sample Area(s)" will recreate the sample area(s) that were removed
when clicking the Reset button or doing adjustments on the Cast tab sheet. "Remove 2. Sample Area" will delete the
second sample area while keeping the first one.

Undo

Clicking the Undo button will simply restore the control settings that were used before the preview was updated again,
because you changed a slider value or pressed a button.

Opening Presets

Several presets for removing different casts or producing artistic effects are already delivered with ColorWasher. They
only deliver rough values, but they may be useful as a starting point for a manual color correction or artistic effect.

When opening a preset from Version 1.0 of ColorWasher, only the two color boxes and the Adjust Cast slider will be
changed. Version 2.0 presets change all settings that are related to the image effect. Exception are the Easy Mode,
Instant Preview, Zoom, Neutral, On Start Up, On Reset, Drag Output, Show Highlights, Histo, Histo Type, SplitView and
Multiple controls.

If you click on the Open button, a file dialog displaying the files of the Presets sub folder will appear and let you select a
preset file. If you right click on the Open button, a menu with the presets from the Presets sub folder will appear instead. If
there are too many presets to fit on the menu, you can use the arrow signs at the top and bottom to scroll the menu.

Saving Presets
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You can save a color preset by clicking on the Save Preset button. Please save presets into the Presets sub folder within
the ColorWasher folder as that is the location where ColorWasher looks for them.

Preset Naming Conventions

If you use an appropriate name when saving a preset, please us the following naming conventions to make it easier to
identify the effect again:

When saving a preset for removing a cast, start the name with "Remove − ". These presets should have a gray
color in the Target color box.

• 

When saving a preset for producing an artistic color effect, start the preset name with "Artistic − ". These presets
usually have a gray color in the Source color box.

• 

When saving a preset for correcting a cast and producing a color effect at the same time, start the preset name
with "Crossover − "

• 

The rest of the name should consist of the color name(s) and/or otherwise descriptive word. Here are some examples of
suitable preset names:

Remove − Yellow
Remove − Slight Blue
Remove − Heavy Pink
Remove − Church Cast

Artistic − Midnight Blue
Artistic − Brighter Sky
Artistic − Turquoise
Artistic − Peach Color

Crossover − Blue to Red
Crossover − Intensify Pink
Crossover − Oversaturated
Crossover − Hue Shift
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Split View

The various split views let you evaluate certain aspects of the image or perform a certain photo correction.

Multiple

The Multiple check box only work in combination with the Split View options. If it is activated you will see the same image
content in each split view area. If Instant Preview is deactivateed, you can hold down and click somewhere to display a
different part of the image in both split areas. If the Instant Preview check box is active, you can alternatively hold down
the Alt key and drag over the preview to make it move. If Instant Preview is switched off, it makes no sense to drag,
because you won't see anything moving.

Using Left, Right, Bottom and Top View

These four split views let you compare the original image with the corrected version side by side. The corrected image will
be displayed at the left, right, top or bottom as the names indicate. To move the separation line between the two versions,
hold down the ALT key and drag on the preview. If you have Instant Preview activated, the effect of moving the separation
line will be immediately visible. Unlike with the other split views, you can't select anything by shift clicking.
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Choosing a Cast Type

The two Cast Types split views let you compare the different cast types as well as choose one of them. The effect of the
six cast types (without Autodetect) is displayed as vertical or horizontal stripes on the image.

Instructions:

1. Create a sample area or use an Auto button

2. Select "CastTypes Vert." or "CastTypes Horiz." from the Split View box

3. Hold down the ALT key and drag on the preview to move the separation lines and view other parts of the image with
another Cast Type. To view the same image content in each split view, please activate the Multiple check box.

4. Hold down the Shift key and click the split area that you like best.

5. As a result Split View will be switched off, the Cast Type combo will be set to your chosen Cast Type and the image will
be displayed with that Cast Type applied.

Hint: While you are in "CastTypes Vert." Or"CastTypes Horiz." mode, you can create or move a sample area, use the
Auto buttons or the manual controls. So you don't need to switch Split View off while doing that. Only when you choose an
item from the Cast Types combo box, these Split View modes will be activated, because otherwise you wouldn't see the
effect of the altered cast type.

Adjusting the Cast

The Adjust Cast option from the Split View combo displays six variations of the Adjust Cast slider.

Instructions:

1. Create a sample area or use an Auto button

2. Select "Adjust Cast" from the Split View box

3. Six horizontal stripes that contains values of the "Adjust Cast" slider will be displayed. At the left you will also see the
plain stripe as an orientation.

4. Hold down the ALT key and drag on the preview to move the separation lines and view other parts of the image with
another Adjust Cast value. To view the same image content in each split view, please activate the Multiple check box.

5. Hold down the Shift key and click on your preferred split area.

6. Result: Split View will be switched off, the Adjust Cast slider will be set according to your choice value and the image
will be fully displayed with that Adjust Cast value.
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Hint: While you are in "Adjust Cast" mode, you can create or move a sample area, use the Auto Buttons or the manual
controls. The Adjust Cast stripes will be updated accordingly.

Color Correcting with the Color Stripes

The two Stripes features let you color correct the image or evaluate different colored versions of it.

Instructions:

1. Select "Hue Stripes" or "Color Temp. Stripes" from the Split View box.

2. Six horizontal stripes that contain the most important hues or color temperature colors will be displayed. At the left you
also see the plain stripe as an orientation.

3. Hold down the ALT key and drag on the preview to move the separation lines and view other parts of the image with
another color. To view the same image content in each split view, please activate the Multiple check box.

4. Hold down the Shift key and click on the split area that looks best to you.

5. Result: Split View will be switched off, the Source and Target color boxes will be filled with your choice and the image
will be fully displayed with the chosen color correction.

Hint: If you create or move a sample area, use the Auto buttons or the manual controls, these two split views will be
automatically switched off. This is necessary, because otherwise you wouldn't see the effect of the altered sample area,
pressed Auto button or altered manual controls . But you can adjust the Contrast and Exposure settings as you like
without leaving this mode.

ColorWasher Manual 28



Color Correcting with the Color Grids

The Grid modes of Split View display a 6 x 6 grid with color variations. The colors in the horizontal direction are the same
as those of the Stripes modes whereas the vertical direction displays the color with different saturation. They let you
correct hue and saturation at the same time.

Instructions:

1. Select "Hue Grid" or "Color Temp. Grid" from the Split View box.

2. A 6x6 grid with various colors will be displayed.

3. Hold down the ALT key and drag on the preview to move the separation grid and view other parts of the image with
another color and saturation. To view the same image content in each split view, please activate the Multiple check box.

4. Hold down the Shift key and click on one of the 36 split areas that looks best to you.

5. Result: Split View will be switched off, the Source and Target color boxes will be filled with your choice and the image
will be fully displayed with the chosen color correction.

Hint: If you create or move a sample area, use the Auto Buttons or the manual controls while you are in "Hue Grid" or
"Color Temp. Grid" mode, Split View will be automatically switched off. This is necessary, because otherwise you wouldn't
see the effect of the altered sample area, pressed Auto Button or altered manual controls . But you can adjust the
Contrast and Exposure settings as you like without leaving this mode.
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Adjusting the Exposure

The Exposure mode of Split View displays exposure variations from − 50 to +75 as six vertical stripes. They represent
values of the Exposure slider.

Instructions:

1. Create a sample area or use an Auto button.

2. Select "Exposure Stripes" from the Split View box

3. Hold down the ALT key and drag on the preview to move the separation lines and view other parts of the image with
another exposure value. To view the same image content in each split view, please activate the Multiple check box.

4. Six vertical stripes that contain values of the Exposure slider will be displayed. At the left you also see the plain stripe
as an orientation.

5. Hold down the Shift key and click on the stripe you prefer.

6. Result: Split View will be switched off, the Exposure slider will be set according to your choice value and the image will
be displayed fully with that Exposure value.

Hint: While you are in "Exposure Stripes" mode, you can create or move a sample area, use the Auto Buttons or the
manual controls, e.g. the Exposure Fix combo box. So you don't need to switch Split View off while doing that. When
using the Exposure slider in "Exposure" mode, Split View will automatically be switched off. This is necessary, because
otherwise you wouldn't see the effect of the altered Exposure slider.
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Histo Tab

Basically histograms don't show anything you can't see in the image itself if you know where to look and look really
closely. But histograms have the advantage that they are more structured than the image itself, so they let you recognize
image problems easier.

A histogram is a statistical display of an image parameter, e.g. brightness, hues or saturation. It shows the distribution of
certain pixel values in an image. These values usually range from 0 to 255 in a 8bit image. The range of these values is
displayed from left to right in the histogram, so the value 0 is displayed at the outer left and the value 255 is displayed on
the outer right side. The amount of each value is displayed from bottom to top, so the height of the curve represents the
number of pixels that have a certain value. If more pixels have a certain value, the histogram curve will be higher at that
point.

In ColorWasher the histogram curve is separate into three areas: the shadows on the left side (with values from 0 to 85),
the midtones in the middle (with values from 86 to 170) and the highlights at the right side (with values from 171 to 255).
ColorWasher displays all three areas equally wide, although some people may argue that the midtones are double as
wide as the shadows and the highlights. But usually it more useful to define the three areas equally wide.

Peak, Mean, Shadows, Midtones and Highlights labels

The Peak figure lets you know which brightness, color or other value occurs most often in the image. The histogram curve
usually has its peak at that value. The Mean figure tells you the average brightness, color or other value. If this value is
below 128, the image contains e.g. more dark then bright areas.

The Shadows percentage lets you know how much of the image is in the lower value range (e.g. is quite dark), the
Midtones figure tells you how much of the image is in the middle range (e.g. is moderately bright) and the Highlights
percentage shows you how much of the image is in the upper range (e.g. is bright). For example if the Shadows
percentage in the RGB or Intensity histogram is very high, it can mean that the photo is underexposed.

RGB Histogram

You can use the RGB histogram to see if there are blown highlights or cutoff shadows in an image. Blown highlights can
be identified by a high spike at the right side whereas cutoff shadows are represented by a high spike at the left side. The
higher and wider the spike is, the more information was cut off.
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If there is large slope on the left or right side and not just a thin spike, then the photos is already quite damaged. Another
bad sign is if the middle part of the curve is quite flat or extremely ducked to the ground. If such histograms are produced
by a correction you did in ColorWasher, you should correct your adjustment.

The RGB histogram also shows the darkest value (the end point of the curve at the left) and brightest value (the end point
of the curve at the right) in an image. Both are also called black point and white point. The range between both points is
called dynamic or tonal range and determines the contrast of the image. The optimal contrast is achieved if the curve
starts at the outer left and ends at the outer right. If that isn't the case, the image may not have a good contrast. If the
curve starts too more towards the middle, it also means that the image is too bright. If it ends more in the middle, then the
image is too dark.

Nevertheless there are always exception from the rule. A photo with a snow landscape will produce a similar histogram as
an overexposed photo, but the snow photo is fine while the overexposed photo needs to be fixed. On the other hand a
photo with a black sky and stars or the moon looks on the histogram as if it is underexposed, although that isn't the case.
So a good rule is to always investigate the image, too, and to not trust the histogram completely.

Small gaps tend do show up in the RGB Histogram more often than in other histogram types. They are only a sign that an
image was processed and are usually nothing to worry about. For more information please see the Histo Fix check box.

Intensity, Luminosity and Lightness Histograms

The Intensity, Luminosity and Lightness histograms are very similar for many images. They often let you better judge the
brightness distribution in an image, but they are not suitable to judge blown highlights or cutoff shadows. If the image
contains more shadows, the hill is more on the left side. If it contains more highlights, the hill is located on the right side. If
it is well balanced, the hill or hills are usually in the middle of the histogram.

If there are two hills, one on the outer left side in the shadows and one on the outer right side in the highlights, it means
that the photo was taken under extreme light conditions and contains too dark as well as too bright areas.

If these hills have its peaks at the outer left and right side, the image has a too extreme contrast. In such a case you
should choose "Balance Midtones" from the Exposure Fix combo box or fine tune the image by using the Highlights and
Shadows sliders to compensate for it.

Red, Green, Blue, Cyan, Magenta and Yellow Histograms

These histograms can be used to recognize color casts or other color problems. For example if the Blue Histogram
contains a curve that is only located in the shadows, it means that there are as good as no light blue areas in the image.
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This can mean that the color blue was suppressed in the image and that the image has a yellow color cast.

Hue Histogram

The Hue histogram lets you see if some hues are missing. If some hues are dominant in the image, it can mean − but not
necessarily − that there is a color cast. A close−up photo for example is usually missing some hues even if it doesn't have
a color cast.

Saturation Histogram

The Saturation histograms lets you see if there is a problem with the saturation in the image. For example if there is
nothing in the left part, the image may be oversaturated or if there is nothing on the right side, the image is probably
undersaturated. However, images with a lot of white and dark areas may appear undesaturated according to the
histogram, but as pure white and black have no saturation, that may not be true.

In such a case you can try the Saturation feature from the Extras tab sheet.

Colors Histogram

The Colors histogram is similar to the RGB histogram, so it also lets you see if there are blown or cutoff areas.
Additionally it shows which hues are dominant in the shadows, midtones and highlights.
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Black and White Histograms

The left part of Black histogram and the right part of the White histograms are similar to the RGB histogram. Both
histograms should fill the whole value range from left to right for a good correction. The above Black histogram indicates
that the image is too "black" and too much "white" at the right end of the histogram is missing. The above White histogram
also has a larger gap at right end, which means that the white values aren't fully used.

If there is a large gap at the right or left end of the histogram, it means hat the contrast of the image is bad. Spikes at the
outer left or right indicate cut−off shadows and blown highlights.

Styles

ColorWasher lets you display the histograms in four different styles. "Filled" created the standard histogram type that is
known from many graphics applications. The "Gradient" option draws a color gradient from left to right. The colors of this
gradient are different from histogram to histogram. The "Line" option draws a line and leaves the area underneath empty.
"Dot" plots the histogram values as dots, which may make some histogram values less readable, but lets you easier
recognize a general trend.
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Info Tab

The Info tab shows some information that is not essential, but may be helpful in certain circumstances.

Show Blown Highlights

The Show Blown Highlights displays highlight areas that were cutoff by ColorWasher as a line pattern in the image.
Additionally activating this check box shows a percent value in the check box label which indicated the percent of blown
highlights. This feature doesn't show blown highlights that were already present in the image before you executed
ColorWasher.

Color Box

When moving the mouse over the preview the color under the cursor is displayed in the color box of the Info tab sheet.
Additionally the color is shown as RGB and HSL values. The x and y values represent the image coordinates.

Render Time

The first value at the bottom shows you how many microseconds the preview update needed. The second figure is the
estimated time in seconds that the final rendering will need after clicking on the OK button. Slow computers need approx.
100 to 200 ms to update an average large preview with average settings, while older computer may need up to a second
or more.
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Prefs Tab

The Prefs tab contains some options for defining the behavior of ColorWasher.

On Start Up

The default "Previous Settings" of the On Start Up control will load the settings that were used to correct the previous
image when running ColorWasher. The "Default Settings" will set all controls back to default values with activated
automatic contrast and exposure correction. "Original Image" will start ColorWasher with no correction applied to the
image. The "Logged Settings" option will automatically open the settings that were applied the last time to the same
image. It only works if you previously had the Log Settings check box activated and if you are using Photoshop or Paint
Shop Pro (see below for more information). The "Auto 1" to "Auto 4" settings will simulate a push of the appropriate Auto
button when ColorWasher starts up.

On Reset

The behavior of the Reset button can be defined by the On Reset combo box. If it is set to "Default Settings" and click the
Reset button, it will deactivate a lot of other controls, but activate the default setting for the Auto Contrast and Exposure
Fix combo boxes. That means you won't see the original image when hitting Reset, but a contrast and exposure corrected
version. To additionally deactivate these three controls please hold down the Shift key and click on Reset.

If On Reset is set to "Original Image" all corrections will be deactivated and the uncorrected image will be displayed in the
preview. If "Preview Settings" is activated on the Prefs tab, clicking Reset will load the settings that were used for
correcting the previous image. If you select "Own Defaults", you will be prompted to select a preset file that was already
saved with the Save button. So if you want the Reset button to revert back all controls to your preferred setting, you have
to save a preset file of that setting at first. See below for more information on saving a preset file.

If you press the Reset button after setting On Reset to "Logged Settings", ColorWasher will look into the logfiles sub folder
inside the ColorWasher folder and see if a preset was saved with the name of the current image. This preset may have
been automatically saved by ColorWasher, because the Log settings check box was activated and you already applied a
correction to this image (or an image with the same file name). If ColorWasher can find a preset file, it will immediately
open it. If ColorWasher doesn't find one, nothing will happen.

Apply B/W

The Apply B/W combo box on the Prefs tab determines the behavior of the B/W button. If you set it to "Before Correction"
and activate the B/W button, the B/W conversion will be done before the correction is applied. That way you can create
colored B/W effects with the help of the Color tab features. The "After Correction" option makes the B/W button behave as
usual and allows you to create B/W variations of your image.

Language

The Language combo box lets you switch between various localizations of the ColorWasher dialog. You can choose to
have it in English, German, Netherlandish, French, Spanish and Portuguese. When running ColorWasher for the first time,
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it will automatically set this option to the language of your Windows installation.

Drag Output

Activating the Drag Output check box updates the preview while you are moving it with the right mouse button or with the
Alt key and the left mouse button. The dragging will be less fluid than with deactivated Drag Output, because
ColorWasher has to recalculate the preview for every move you make. It is not recommended to use this feature with
slower computers.

Histo Zoom

Activating the Histo Zoom check box in the Prefs tab cuts off peaks for some images when displaying a histogram in the
Histo tab sheet. This avoids a flat histogram display where only a few high spikes are visible. That's also how Photoshop
displays histograms. This options is activated by default.

Log Settings

With activated Log Settings check box ColorWasher automatically saves preset files in the logfiles sub folder of the
ColorWasher folder when you press the OK button to apply a correction to an image. In Photoshop and Paint Shop Pro
the presets are named with the file name of the image. In other applications a random number is used, because these
applications don't supply the file name of the image to plugins like ColorWasher. If you apply ColorWasher a second time
to the same image and have Log Settings activated, the previous preset file will be overwritten.

At least with Photoshop and Paint Shop Pro this feature allows you to easily find the settings that you applied to certain
images by looking into the logfiles sub folder. For other applications you can only look at the file date and guess which
preset files was used for which image.

In connection with the Logged Settings option of the On Start Up combo box (see above), you can use the Log Settings
check box to automatically make ColorWasher start up with the settings that were applied the last time to the same image.
So if you need to correct the same image again, you will automatically be presented with the same settings that you used
the last time.

In case you don't want to start up ColorWasher with the logged settings or forgot to activate that option, you can also open
the logged settings by right clicking on the Reset button and choosing "Logged Settings" from the context menu.
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Cloak Mode

In Cloak Mode Color Washer doesn't display its dialog and immediately starts rendering a predefined setting to the image.
Cloak mode is useful if you want to quickly apply the same settings to a series of photos.

Activating Cloak Mode

To activate Cloak Mode please hold down the CTRL key and click on the Cancel button. You will get a message with
some information and for confirming Cloak Mode. After pressing YES, the current settings are saved and ColorWasher is
exited without rendering an effect to the image. Now when you run ColorWasher again by choosing it from the Filter menu
of your image application, the dialog of ColorWasher won't show up and the previous settings will be rendered
immediately to the image.

If you want to apply ColorWasher in Cloak Mode to series of photos with basically the same color cast, you can test
ColorWasher on one or more of them and adjust the settings to match all or most of the photos. If you create a sample
area and switch to Cloak Mode, only the colors that were sampled will be applied in Cloak Mode. The same area won't be
sampled for each photo, because that would lead to bad results in most cases.

If you want to apply ColorWasher in Cloak Mode to photos with different color casts, please click on one of the Auto
buttons (preferable Auto 1 or Auto 2) before CTRL−clicking on the Cancel button. This will make ColorWasher use the
automatic color correction during Cloak Mode. The Prefs > On Start Up setting is ignored in Cloak Mode.

Leaving Cloak Mode

After you processed your series of photos in Cloak Mode you can uncloak ColorWasher again. To do that hold down the
Shift key when selecting ColorWasher from the filter menu in your image application. This will display the ColorWasher
dialog again and exit Cloak Mode.

Alternatively you can also delete the file Cloak.ini in the ColorWasher folder. But this is just an emergency strategy.

Batch Processing in Cloak Mode in Photoshop

Photoshop offers a Batch feature on its File > Automate menu. This feature lets you batch process a series of images with
the help of a Photoshop Action. So if you want to batch process images in Photoshop you only need to record an action
that contains ColorWasher.
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To record an action with ColorWasher do the following:

1. Open an image in Photoshop.

2. Switch to the Actions palette at the right and create a new action by using the New Action button or the pop−up palette
menu.

3. Choose ColorWasher from the Filter menu and press OK. You don't need to adjust any setting or enter Cloak mode yet.

4. Press the Stop button on the Action palette. Now you have your ColorWasher action that you can use with File >
Automate > Batch.

To batch process a series of images with Color Washer please do the following:

1. Open one of the images from the image series.
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2. Run ColorWasher and adjust its settings.

3. Enter Cloak Mode by holding the CTRL key and clicking on the Cancel button.

4. Select File > Automate > Batch.

5. In the Batch dialog make sure that your ColorWasher action is selected.

6. Set the other batch options and click on OK to run it.

If you want to batch process another series of images with other ColorWasher settings, please uncloak ColorWasher as
mentioned above, adjust the settings and return to Cloak Mode again. You don't need to create another action for that
purpose as you would need to do for other plugins.

If you want to apply individual ColorWasher settings to each image during batch processing, don't activate Cloak mode
and run the action nevertheless. Then for each image the ColorWasher dialog will pop up for adjusting the settings. To
apply them just click on OK.

Batch Processing in Cloak Mode in Paint Shop Pro 8 and higher

Paint Shop Pro 8 and higher offer a Process feature on the File >Batch menu for batch process a series of images with
the help of a PSP script. Recording such a script is quite easy.

To record a PSP script with ColorWasher, please do the following:

1. Open an image in PSP.

2. Select File > Script > Start Recording.

3. Choose ColorWasher from the Filter menu and press OK. You don't need to adjust any setting or enter Cloak mode yet.

4. Select File > Script > Start Recording and save the script. Now you have your ColorWasher action that you can use
with File > Batch > Process.
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To batch process a series of images with ColorWasher please do the following:

1. Open one of the images from the image series.

2. Run ColorWasher and adjust its settings.

3. Enter Cloak Mode by holding the CTRL key and clicking on the Cancel button.

4. Select File > Batch > Process.

5. In the Batch Process dialog choose your ColorWasher script with the Browse button from the Script frame.

6. Set the other batch options and click on the Start button to run it.

If you want to batch process another series of images with other ColorWasher settings, please uncloak ColorWasher as
mentioned above, adjust the settings and return to Cloak Mode again. You don't need to create another script for that
purpose as you would need to do for other plugins. If you want to apply individual ColorWasher settings to each image
during batch processing, don't activate Cloak mode and run the script nevertheless. Then for each image the
ColorWasher dialog will pop up for adjusting the settings. To apply them just click on OK.

Batch Processing in Cloak Mode in other applications

There are some other applications that support batch processing with the help of plugins. For example, Equilibrium
Debabilizer supports it and some other applications like Plugin Commander Pro may support it in future. Basically batch
processing in other applications works the same as in Photoshop. You have to activate Cloak Mode in ColorWasher and
select the ColorWasher plugin for batch processing in the batch feature of these applications.
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Sample Area

The sample area is a semi−automatic feature of ColorWasher. You can perform the most accurate color corrections with it
if you use it correctly. The displayed sample area marquee looks similar to what you know as selections in various image
editing applications, but it is used for a totally different purpose. The area that is enclosed with the marquee is only
evaluated by ColorWasher for measuring the color cast.

Creating a Sample Area

To draw a sample area please click on the preview, keep the left mouse button pressed and move the mouse to draw the
marquee. The enclosed area is the sample area which will automatically be evaluated by ColorWasher. ColorWasher will
then fill the source target box with the measured color of the color cast and set the Target color box to neutral gray.
Additionally the color correction will be applied to the preview image.

If the Instant Preview check box is activated, the calculated color correction will be applied to the preview while you are
drawing the sample area marquee. This gives you an immediate feedback of the effect of the sample area and helps you
to create a suitable one. If you have a slow computer you should deactivate Instant Preview or make the preview image
smaller with the zoom buttons.

Creating a Second Sample Area

For very difficult photos it can help greatly to draw a second sample area in a different part of the image to produce a
more balanced color correction. To create a second sample area hold down the shift key, click on the preview, keep the
left mouse button pressed and move the mouse to draw the marquee. If you want to redraw the second sample area,
perform the same action again. If you redraw the first sample area, the second sample area will be preserved. To get rid
of the second sample area while preserving the first one, please right click on the Reset button and select "Remove 2.
Sample Area".
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Where to Create a Sample Area

Creating a sample area above a sufficient image area can be a tricky business. Here are some rules of the thumb
concerning sample areas:

1. Create a sample area above an area of the photo that was white or neutral in the original scene.

2. Use the Neutral button to get an idea about which part of the photo is suitable for a sample area.

3. Make the sample area as large as possible. If you have several choices in the photos, better create it above a larger
object than above a very small one.

4. If the white or gray object in the photo is round don't let the sample area marquee exceed its borders. Better to leave a
part of the object uncovered than to make the sample too large.

5. Creating a sample area above an area that is too dark or too bright usually produces unsatisfactory results.

6. If you have some objects in the image with different gray variations, try all of them and keep the sample area that
produces the best results.

7. Activate the Neutral button below the preview to make ColorWasher blend out image areas that are not suitable for a
sample area. The remaining areas are usually good candidates. But don't trust this feature too much as it can fail with
some images.

8. If there is no pure white or gray area in the image, try an almost neutral area, e.g. a washed out sky, grayish water or
color−poor clothes.

9. If you have more photos with the same color cast, try to find one with a previously gray or white area. Use the sample
are on it and correct the other photos with the same settings.

10. If nothing helps, better try the Auto buttons or manual controls.

Places of creating a sample area could be gray clothes, a white T−shirt, white cloth, a white or gray paper, the white area
in an eye, teeth, gray asphalt, clouds, white furniture, white walls or snow. But please try to comply to the rules above. A
part of the image that looks good for placing an sample area may not work well if it is too bright or dark.

Please remember: You will get better at creating the correct sample areas with every new image you try. It might take a
bit of time to become an expert, but it is worth practicing this technique. It allows and sometimes even demands some
creativity from you and can help you produce the best color correction results. Everyone can press an Auto button, but
creating a sample area needs a bit more skill.

Sample Area Hints

The text box at the right bottom displays hints that refer to the sample area that you created. This can be quite helpful if
you don't have much experience with drawing the sample marquee.

If the area which is enclosed by the sample marquee is too dark or too bright, the text box will let you know. You will also
get a warning if the sample area is too small or encloses an area that is too colored. If you get such a warning and are
certain that you have done right or can't find a better area to sample, please ignore the warning. If the Instant Preview
check box is activated, the text box will already display recommendations while you are still creating a sample area.

Visual Examples

Here are some example that demonstrate where to create a sample area:
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Corrected
Version with

Sample
Marquee

The snow in this photo looks very blue. The
Neutral button shows very clearly were we can
place our sample area.

We placed the sample area in the largest white
area and get a very good result. That was easy!

This image has a strong yellow cast as it was
taken indoors. The Neutral button shows that we
could select the drawing at the top or some parts
of the table cloth. The pullover of the old woman
wouldn't be a good choice as I remember that it
originally was not pure white or gray.

All four sample areas that you can see in the
image would work nice. We decided to use the
one at the bottom middle as it is the largest.
Wow! No yellow cast isn't visible anymore and
the colors became real vivid.

This is an old photo from the 70ies. It became
quite faded and yellowed in the meantime. The
Neutral button shows that it is best to select the
ground. Asphalt is often a good choice for a
sample area.

The Linear Cast Type produces the best result
with this photo. The color are reconstructed quite
nicely. The photo also gets that nostalgic old
look again.
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This cow looks kind of green. Is she ill? Maybe
we can restore her health with ColorWasher. The
Neutral button shows the brown back as a
candidate for the sample area, but we won't do
that.

Instead we placed a sample area on a part of the
cows white mouth. Now the cow has her nice
brown skin back and the autumn leaves in the
background look more vibrant, too.

Moving the Sample Area

Sometimes you create a sample area that doesn't fit that good. In this case you have two choices: You can try to create
the sample area again or you can try to move the current sample area marquee. To move the marquee hold down the
CTRL key and drag the sample area above the preview.

This technique can also be used to search the image for a right place for the sample area, especially when you have the
Instant Preview check box activated for receiving immediate feedback.

Advanced Sample Area Techniques

In some cases it might prove profitable to use the sample area marquee in an unusual way. For artistic effects you could
select an area that is not really gray or white. Moving the sample marquee to do that can be fun.

You could use the sample marquee similar to the color picker to load a certain color into the Source box and to add a
Target color of your own. This method can be used to color−correct a photo and to colorize it at the same time, but you
can also do that if you want to convert a certain color in the image to another color.

Selecting neighboring image areas with different gray or white variation can produce better results sometimes. This
makes sure that more or less the average of these gray variations is sampled. This technique can sometimes improve the
color correction quality and helps you cope with tricky photos that contain more than one color cast.

If a part of a image has a different color cast than the rest of the photo, please create an image selection in your image
application for it and use ColorWasher only on that selection. Such a case is demonstrated in the following example.

Advanced Visual Example
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A friend of mine purposely set up a very
difficult−to−color−balance shot to test our color
correction skills. It consists of a few objects, a live
monitor display, and lit with halogen spots and one
weak tungsten overhead lamp. Our friend was so
kind to white balance to the halogen lamps only.
Grrr.... This really looks like a color−correction
nightmare...

OK, lets do this step by step. First of all we want to
get rid of that red cast at the bottom. We place our
sample area at left bottom and try each of the Cast
Types. Luckily the Linear cast type manages to
remove the red casts completely. Hurray! But the
screen still looks very unnatural.

OK, we need to color correct the screen only, so we
create a feathered selection of the screen in our
image application and run Color Washer on it. We
create a sample area at the top right of the screen
and switch back the Cast Type combo to Auto
detect. Good, there's no color cast on the monitor
anymore.

As a final step, lets try to give this shot more depth.
In ColorWasher we use the Reset button and
decrease the Highlight slider to makes the monitor a
bit dimmer and increase the Shadow slider slightly.
Looks like the photo has more depth of field now. My
friend is going to get real envious about our skills
:−))).
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Auto Buttons

The five Auto buttons which are located at the top right of the ColorWasher window let you perform an automatic color
correction when clicking on them. This is a quick and easy way to color correct your photos. Each button has its
advantages and disadvantages. So you should try all five Auto buttons before you decide which one achieves the best
result for the current photo.

You can use the Auto buttons as a first start and edit the measured colors with the color boxes and sliders. But you can
also use them if drawing a sample area on the preview doesn't achieve suitable results, because there is no gray or white
area present in the image.

Nevertheless a good sample area usually produces a more accurate color correction than the Auto buttons. So if you want
a perfect color cast removal, try drawing a sample area firstly.

Auto1 − "The Generalist"

The Auto1 button works properly on color casts that are visible throughout the image. That's because Auto1 analyses the
whole image data for detecting a color cast.

Auto 2 − "The Wise"

Auto2 does a good job on images which are not too bright and not too dark. It analyses the midtones of the image to
detect a color cast. Auto2 also works well on less obvious color casts. Together with Auto1 it works fine on most photos.

Auto3 − "The Illuminator"

Auto3 might work better than the other Auto buttons in some cases (e.g. when a white T−shirt or dress is visible in the
photo). It is specialized on analyzing the highlights of images. So it should work fine on very bright images that aren't
overexposed. Using Auto3 on images with overexposed areas often produces a less good result.

Auto4 − "The Combinator"

Auto 4 combines results of Auto1, Auto2 and Auto3. That means if two of the three work fine, Auto4 will work very good.
While it works fine on many images it often doesn't work as good as one of the first three Auto buttons alone.

Auto5 − "The Smurf"

The Auto5 button is a very special case. We noticed that the other three Auto buttons didn't detect certain blue casts, so
we decided to develop the Auto5 algorithm. It is basically a mixture of Auto1 and Auto2, but is less effective on most
images than these. Auto5 can fail miserably on some images, but it might do wonders on strong blue casted or otherwise
difficult images.
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Cast Types

The Cast Type combo box lets you choose between seven methods for removing color casts from images. Each method
or cast type has its powers and weaknesses and works better on certain photos than the other. When processing very
weak color casts, there is not that much difference between the different cast types. But with a medium or heavy color
cast the different mechanisms of the cast types become quite obvious. Although it isn't their main purpose, you can also
use the cast types to produce color casts in an image and thus create artistic effects. Additionally the Adjust Cast slider
below the Cast Type combo box lets you adjust the intensity of the applied color correction.

Precise Check box

With deactivated Precise check box ColorWasher very slightly increases the brightness of the image when correcting it.
This may be a problem for images that have strong highlights. If you activate the Precise check box the original brightness
of the image is retained and highlights will be treated more carefully, but render time is increased by 25%.

Autodetect

Normally you should keep the Cast Type combo box set to Autodetect, because Autodetect automatically switches
between three different Cast Type options to achieve optimal results with most images.

If you are not satisfied with the result of Autodetect, please manually choose one of the other available cast types.
Autodetect was designed to be used on photos, so if you are processing drawings, comics or screen shots, please try one
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of the other cast types. The most effective cast types are Standard, Green Cast and Red/Orange Cast. The other cast
types can be very helpful for special cases.

Standard

The Standard option is very good for color correcting photos, so it is used for most photos if the Autodetect option is
selected. It usually removes color casts very efficiently from all areas of a photo. If an area of the photo is overexposed it
can mask it in many cases to make the overexposure less visible. However, it may not work that well for green, red or
orange casts as well as non−photographic images. In that case please select one of the options below.

Green Cast

The Green Cast option can remove green color casts very efficiently. In some cases it works fine on other color casts, too.
It works less well on drawings and similar artificial graphics.

Red/Orange Cast

The Red/Orange Cast option is well suited for removing red and orange color casts, but can also used for other color
casts. Especially if the image looks as if it is oversaturated, this options is often the best. Nevertheless it may leaves a
good deal of the color cast in the image if the color cast is quite strong. This is also useful if you basically like the color
cast of a photo, because it intensifies the atmosphere of the photo. In such a case it can be used to only reduce the
dominance of the color cast.

Standard Light

Standard Light is a variation of the Standard option. It keeps color casts in the shadows, which may look better on some
photos.

Special Case

The Special Case option tends to create more vivid colors than other cast types. It sometimes also manages to remove
color casts more effectively than the other cast types, especially if the heavy casts and casts on older photos. It is also a
good candidate for drawing or other non−photographic images. However, in some cases it doesn't remove color casts that
effectively in dark areas and doesn't hide overexposed areas that perfectly.

Old Photo

If you like to correct old and faded photos, you should definitely try the Old Photo option. But even for digital photos it
might produce a better result in some cases. For example, if an photo contains clean bright white tones, but nevertheless
a color cast in it, it may do the best job. It also tends to reproduce skin tones more pinkish which may be preferred by
some people.

In many cases, especially with digital photos, Old Photo tends to turn white areas into some old yellowed ones. If you like
to turn your photo into an old looking one, don't hesitate to use Old Photo.
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Extreme

As its name suggests, can produce very extreme results, but in some cases it works similar to Special Case. Whereas the
other cast types try to reconstruct image areas that were clipped by the color cast, the Extreme option doesn't do such a
thing. That's why it may produce not so good results on several photos. It may lower contrast and create a strong
antagonistic color cast.

But nevertheless it can be the only choice for some images. For example if you apply it to an image with only a slight cast,
it can mask overexposed areas and restore the image effectively. Extreme may also work good on extreme color casts
that suppress most of the other color in a photo.

The Adjust Cast Slider

Using the Adjust Cast slider is only necessary in very few cases. You can basically increase or reduce the intensity of the
applied the color correction with it. This might be helpful when correcting a close−up shot with a limited number of hues.
For such images it is often quite difficult to predict how the colors were originally. Adjusting the cast intensity helps
sometimes to produce a result that matches your taste better. If you use the Auto buttons or create a sample area on the
preview, the Adjust slider is automatically reset to zero.

What the Adjust Cast slider basically does is to internally change the saturation of the cast color, which is displayed on the
Adjust Cast slider as well as in the Source color box on the Color tab sheet. Therefor the Adjust Cast slider won't work if
the Source color box contains a gray value.

The Highlights and Shadows Sliders

The Highlights and Shadows sliders work very similar to the Adjust Cast slider. Whereas the Adjust Cast slider adjusts the
overall color correction, the Highlights and Shadows sliders adjust the color correction in the highlight or shadow areas
only. This gives you much more control for fine tuning the color correction. However, using these features is only
necessary for very difficult to correct photos.

The Cast Statistics Text Label

If you created a sample area or clicked on an Auto button, ColorWasher calculates the cast strengths before and after the
correction and displays them in the white text field at the bottom of the Cast tab sheet.

The first value called "Cast" is the measured cast strength in percent in the original image. Weak color cast as can be
seen in a lot of images have a Cast value of 10% or less. They are usually not noticed by untrained eyes, although the
difference can be clearly seen after removing it. According to our experiences photos with cast values below 50% (which
is already a very strong cast that dominates the whole image) can be fixed very effectively. In one case we also managed
to sufficiently remove a 70% red color cast although we wouldn't have believed that any color was left in the image. So we
estimate that a Cast value between 50% and 75% can be fixed more or less sufficiently. Above 75% a lot of color
information has been suppressed in the image. So sometimes your only chance to remove the color cast it is to convert
the image to B/W by activating the B/W button.

Theoretically it is also possible that the Cast value exceeds 100% and runs up to 200%, although we can only imagine
that such a color cast can be produced artificially. Such an image would be completely green or magenta. In that case you
can forget about the image and can only hope to produce a B/W image with a more or less bad contrast.

The second value called "Remaining" represents the remaining cast strength in the corrected image. It should be below
1%, otherwise your correction is probably not that good. In that case please try different settings and see if you can
achieve a better correction. Anyway, if you like the result and don't manage to get a better correction, you should trust
more your eyes than this figure. Especially when using the Red/Orange Cast option the color correction may be sufficient,
although the Remaining value is above even 20%.

The Cast and Remaining percentage values describes the deviation of the cast color from Neutral Gray. A neutral gray or
white has a value of 0%. A cast color that is fully saturated has a value of 100%. The only exceptions are green and
magenta. If they are fully saturated they theoretically can have a value of 200%, although that value is practically never
reached. Basically the more saturated a color cast is, the stronger is it.
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The third value called "Effectivity" tells you how effective the correction was. It should be near 100% or at least above
90%, otherwise the color cast wasn't removed completely.

If you use the manual controls from the Color tab to select a source color, only the first value will be displayed.
ColorWasher assumes in that case that you selected the cast color manually. As it didn't detect the color cast itself, it has
no means to tell you how good your color cast guess was. It can only tell you the strength of the cast that you manually
selected.
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Color Tab

Once you have mastered the Easy Mode and start using the Advanced Mode, the Color tab may play an important part
when using ColorWasher.

The Color Boxes

One of the two color boxes is selected when a frame is displayed around it. To select the other color box, simply click on
it. The color values of the currently selected color box will be displayed by the three slider below and can be edited.

The Source color box usually displays the color of the color cast that is present in the image. When using the Auto buttons
or the sample area marquee, the Source color box is automatically filled with the cast color. That gives you the possibility
to further adjust the color of the cast if you like.

The Target color box determines how the color of the Source color box will look like when the image is processed. If you
want to remove a color cast, the Target color box should always be neutral gray. Neutral gray means that, for example the
Red, Green and Blue slider should have the same value, that the saturation should be zero or that the two color sliders of
the Lab and YCbCr model should be set to 128. For artistic color effects you can set the Target color box to a different
color.

The Balance button between both color boxes lets you adjust the lightness of one color boxes in relation to the other. If
the Balance button is activated, the lightness of the selected color box will be set in the non−selected color box. This
ensures that the brightness of the image will stay the same while you edit the color boxes.

Using the Color Dialog

You can display a color dialog for changing the color of the selected color box by clicking it. That means: One click on the
color box to select it and another click to display a color dialog. The displayed color dialog will be the color dialog that you
already know from your image application. The color dialogs of some image applications are quite sophisticated, other are
less useful. ColorWasher passes the color of the color box to the color dialog, so you can adjust it there and return it
again.

Unfortunately a few applications don't support color dialogs, but tell that to the plugin. As a result there will be no color
dialog displayed. Examples of such applications are IrfanView and PhotoBrush.

Using the Color Picker

You can activate the color picker by clicking on the button on the left−hand−side of the Source Target box. When you then
move the mouse cursor above the preview then it will turn itself into a color picker tool. Clicking on the preview with the
color picker tool, displays the grabbed color in the currently selected color box and deactivates the color picker. If you
want to deactivate the color picker without grabbing a color from the preview, simply click on the color picker button again.

With the Balance button activated, you could of course use the color picker instead of the sample area marquee. But be
warned, the sample area marquee is much more precise when it comes to color correction than the color picker tool.
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The Color Models

Color Washer offers various color models for adjusting the color of the Source and Target color boxes. Selecting a new
item causes the three sliders below to be adjusted to the change and to exchange their names accordingly.

The RGB color model is probably the most known one, because it is used internally by all video cards and monitors. If you
want to select a certain color, you will optimally achieve that with the RGB sliders.

The HSL color model is very important, too, because it splits the color into hue, saturation and lightness. That means that
you can edit the hue, which is the basic color component, independently. That's why the HSL sliders are very convenient
for adjusting colors or creating color variations.

The Lab and YCbCr models are more of exotic nature as far as their usage in ColorWasher is concerned. Lab is an old
color model that is also available in Photoshop and can be used for special purposes. It consists of a Lightness and two
color dimensions. YCbCr which is used for JPEG compression is similar to Lab, but closer related to RGB. It consists of a
Luminancy dimension which is very similar to Lightness and two color components.

The Color Model combo box contains a fifth item called Color Temperature which is a special case. In fact it isn't a real
color model or at least a limited one. The first component of this model is the color temperature which is measured in
Kelvin. Theoretically it represents the colors that a "black body" emits when it is heated up, e.g. from 1000 to 9000 Kelvin.
The Color Temperature slider therefore lets you select values between 1000 and 9000 which correspond to a color
gradient of Red−Orange−Yellow−Blue. Hues like magenta, cyan or green are almost not represented in this model or only
occur in a very limited range. As this color temperature scale only incorporates a limited saturation and brightness range,
two sliders with these dimensions were added. This will allow you to use the Color Temperature scale more effectively for
color correcting photos or selecting certain colors.

Here is an overview of the Color Temperature scale:

Kelvin Description
1000 − 2000 Candle, Weak Flash

2000 − 2500 Sunset, Sunrise

2500 − 3000 Household Bulb, Incandescent

3000 − 3500 Halogen Lamp, Studio Lights

3500 − 4000 Carbon Lamp, Arc Lamp

4000 − 4500 Fluorescent Bulbs, Flash

4500 − 5500 Daylight, Electronic Flash

5500 − 6000 Sunlight

6000 − 7000 Bright Sunshine, Strobe

7000 − 7500 Cloudy, Sky Slightly Overcast

7500 − 8000 Overcast Sky

8000 − 8500 Hazy Sky, Slight Shade

8500 − 9000 Shade, Rain

Using the Sliders

Depending on the selected color model, the sliders represent the dimensions of this color model and let you adjust them.
By changing the slider values you can edit the color of the currently selected color box. The color in the selected color box
will change as you move a slider knob.

To scrub through the values of a slider hold down the Shift key and drag the slider knob. This will make the preview
update instantly with every movement of the knob. With the Balance button activated, you can easily use this method to
find and correct a color cast in the image. If you have a slow computer, don't do it unless you want to wait some time until
the knob comes to a halt.
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Advanced Techniques

As already mentioned you can use the color boxes, color model combo, the Balance button, the color picker and the
sliders to creatively remove a color cast or colorize the image. Try experimenting with them and have some fun!
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Auto Contrast

As the name Auto Contrast says, this feature automatically calculates the optimal contrast for each image if it is activated.
Other than adjusting the contrast with a simple contrast slider, Auto Contrast doesn't cut off details in the dark or bright
areas and doesn't produce burned artifacts or a faded look unless you use an Extreme value. Depending on the initial
contrast in the image, Auto Contrast will more or less also increase the brightness of the image.

The Auto Contrast Options

The Auto Contrast combo box lets you choose between six options and an Off and Manual setting. Each the six options
corresponds to a certain value that is set in the Contrast slider. Here are the descriptions of these options:

Setting Description

Off Deactivates Auto Contrast.

Mild
Applies the weakest possible contrast correction. Images with a very low contrast will even
improve dramatically with this setting. For others you might not see a difference to Off.

Normal
Recommended for most cases. It produces a contrast enhancement without cutting off too
much details in the dark and bright areas.

Strong Will improve contrast even more in some cases.

Intense
If you prefer an intensive contrast in your images, you should use Intense. For some images
it may already produce slightly burned or darkened areas.

Extreme
Usually not recommended. In most cases it creates white edges in the image that causes an
overexposed look. Only very few images will benefit from the Extreme setting.

Manual
Lets you adjust contrast manually with the Contrast slider. This works very similar like the
Contrast slider you are used from common graphics applications. This feature can produce
very unbalanced contrast reduction or increase, so it is normally not recommended to use it.

If you apply ColorWasher on a screen shot, a graphic or other non−photographic material with only few colors, it is better
to switch Auto Contrast to Manual and to use the Contrast slider carefully.

Boost

The Boost check box additionally increases the contrast. This feature is especially useful for photos that have a very small
deep black areas, but nevertheless a bad contrast. This is usually represented by spikes on the left or right side of the
histogram. Without activated Boost increasing Auto Contrast or the Contrast slider may appear to have no or only little
effect in such a case.

When using Boost you should use a smaller value for the Contrast slider to avoid blown highlights. You can check your
image for blown highlights with the appropriate check box from the Info tab sheet.
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The Contrast Slider

The Contrast Level slider is for adjusting the Auto Contrast setting. So if you want to apply a contrast correction that lies
between one of the Auto Contrast options, you should use this slider.

Sat Fix

If the 'Sat Fix' check box is activated, ColorWasher will process the image while keeping saturation constant when
adjusting contrast, exposure, highlights, midtones and shadows. This can improve some photos and avoid oversaturation,
but sometimes if the adjustment is too strong, it decreases or increases saturation too much. In such a case it is better to
deactivate the Sat Fix check box. An alternative to Sat Fix is the Saturation slider.

Histo Fix

The 'Histo Fix' check box removes gaps that can be seen in the histogram view of a corrected image. This means that the
number of colors in the image will increase.  These gaps are only a sign that a photo was corrected, but otherwise you
can forget about them. Please only use 'Histo Fix' if you don't plan to sharpen the photo, because sharpening
automatically removes the histogram gaps. However, this feature produces a larger JPG file size.
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Exposure Fix

ColorWasher offers a special method for adjusting photos that were exposed with a wrong exposure time. Many image
applications offer a brightness slider which usually produces shifted colors, a faded look, a lowered contrast and cutoff
details in shadows and highlights. Another method that is offers by many image applications is called gamma correction.
This method is used for adjusting the brightness of monitors and was also used by ColorWasher 1.0. It works relatively
well, but for stronger adjustments it cuts off details in the shadows and lowers contrast. ColorWasher 2.0 now uses a
superior method that avoids these side effects.

The Exposure Fix Options

The Autodetect option of the Exposure Fix feature will automatically choose between Remove Shadows, Balance
Midtones and Fix Highlights options. However, it tries to preserve the character of the photo. So in the case of a photo
with a lot of shadows it won't try to completely lighten the shadows to remove them completely. It assumes that the photo
is partly attractive because of these shadows. If you prefer well lit photos, you should better set Exposure Fix to "Balance
Midtones" which will lighten shadows relatively strongly.

If a photo is very bright, Autodetect will reduce brightness to compensate for that. If a photo has a lot of overexposed
areas, Autodetect won't change the brightness, because reducing it won't help in that case. Photos that largely consist of
a bright area, e.g. sky or a wall, may be wrongly interpreted by Autodetect and darkened, although it would be necessary
to brighten a small object in the foreground. In that case please choose one of the three other options.

Using one of the Remove Shadows, Balance Midtones and Fix Highlights options is sometimes more or less a matter
of taste. For example if you prefer photos that have deep shadows, you can set Exposure Fix to "Remove Shadows". If
you prefer photos that are evenly lit, you should choose "Balance Midtones" setting. The "Fix Highlights" setting is meant
for fixing overexposed photos. Don't use it with underexposed photos as it may brighten them too much.

The Normal to Extreme settings of Exposure Fix were the main options of Version 1.0 of ColorWasher. With the four
new Exposure Fix options they are more or less obsolete. They are less reliable than the new options. For example if you
apply ColorWasher to the same image again, they will increase or reduce the brightness a second time instead of
applying no adjustment like the new options. Additionally they sometimes don't adjust the brightness enough.
Nevertheless they were left in Version 2.0 to easy the transition to the new features.

The Exposure Slider

The Exposure slider can be used to adjust the Exposure Fix option. Its unit is Exposure Value (EV) from −3.00 to +3.00.
This slider works just like the exposure compensation feature of cameras, which usually range from −2 to +2 EV in 1/2 or
1/2 steps. Usually a higher exposure values means less light, but so it would be more correct to use negative values for
increasing exposure. But to avoid confusing users and to make it work more logically, we use positive values for
increased exposure. The exposure compensation feature of cameras do that, too.

An increase of one EV corresponds to setting the next lower f−number or next higher exposure tome on your camera. For
example if the photo was takes with an aperture of f/5.6 and a exposure time of 1/60 second, a setting of −3.00 simulates
how the photo would look if it was taken with an aperture of f/16 or with an exposure time of 1/500 second. A setting of
+3.00 simulates an aperture of f/2 or an exposure time of 1/8 second. Of course ColorWasher is bound by the data that
the camera has recorded, but it tries to lure hidden information that is compressed in the shadows or stretched in the
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highlights.

Please notice that the Exposure slider works non−linear. The strongest effect is visible between +0.00 to +1.00, the
exposure is less strongly increased between +1.00 and +2.00 and even less between +2.00 and +3.00. Using an
exposure value that is smaller than −2.00 or larger than +2.00 is usually not recommended. Only if your photo is
extremely over or underexposed it may help to make the photo more presentable.

The Sensitivity Slider

The Sensitivity slider defines how strong the exposure correction affects the shadows and midtones. A larger value
produces a stronger contrast and more saturated colors and preserves the shadows better. So it basically lets you adjust
the shadow and midtone contrast of the exposure adjustment. The sensitivity adjustment is especially effective and may
be necessary for exposure corrections of more than −/+ 1.00 EV. Below that value its effect is not that clearly visible.

Sat Fix

If the 'Sat Fix' check box is activated, ColorWasher will process the image while keeping saturation constant when
adjusting contrast, exposure, highlights, midtones and shadows. This can improve some photos and avoid oversaturation,
but sometimes if the adjustment is too strong, it decreases or increases saturation too much. In such a case it is better to
deactivate the Sat Fix check box. An alternative to Sat Fix is the Saturation slider.

Histo Fix

The 'Histo Fix' check box removes gaps that can be seen in the histogram view of a corrected image. This means that the
number of colors in the image will increase.  These gaps are only a sign that a photo was corrected, but otherwise you
can forget about them. Please only use 'Histo Fix' if you don't plan to sharpen the photo, because sharpening
automatically removes the histogram gaps. However, this feature produces a larger JPG file size.
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Highlights / Shadows

The top four sliders on the Extras tab are meant for adjusting the brightness of specific areas of the image. They let you
increase or decrease the brightness of the bright and dark areas independently. They can be seen as an fine tuning
mechanism for the Exposure feature of the Brightness tab.

Adjusting the highlights or shadows is partly a matter of taste, but you can use these sliders to emphasize certain image
areas and reveal hidden details from the dark or bright areas. To avoid producing artifacts or hard edges in the image,
each slider also slightly increases the other brightness area. Additionally the sliders are limited to a certain range,
because larger or smaller slider values would damage the image by producing popart−like effects.

You can also use the Highlights and Shadows sliders to adjust the midtone contrast of the image. For doing that you have
to set the Highlights slider to a negative value and the Shadows slider to a positive value.

The Highlights Slider

This slider lets you amplify or suppress the bright image areas. Don't increase the slider value too much unless you to
want to risk overexposing certain image areas.

The H−Contrast Slider

The H−Contrast slider controls the contrast of the highlight adjustment. A larger value produces more contrasty
adjustment. A low value may produce a too flat and saturated effect. If the Highlights slider is set to zero, the H−Contrast
slider has no effect.

The Shadows Slider

Making darker areas in the image more visible can be achieved with the Shadows slider. But don't boost the shadows too
much or they may get a somehow faded grayish look, because they were shifted into the midtones.

The S−Contrast Slider

The S−Contrast slider controls the contrast of the shadow adjustment. A larger value produces more contrasty
adjustment. A low value may produce a too flat and saturated effect. If the Shadow slider is set to zero, the H−Contrast
slider has no effect.

Sat Fix

The Sat Fix check box from the Brightnes tab also influences the Highlights or Shadows slider. If the 'Sat Fix' check box is
activated, ColorWasher will process the image while keeping saturation constant when adjusting contrast, exposure,
highlights, midtones and shadows. This can improve some photos and avoid oversaturation, but sometimes if the
adjustment is too strong, it decreases or increases saturation too much. In such a case it is better to deactivate the Sat Fix
check box. An alternative to Sat Fix is the Saturation slider.
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Histo Fix

The 'Histo Fix' check box removes gaps that can be seen in the histogram view of a corrected image. This means that the
number of colors in the image will increase.  These gaps are only a sign that a photo was corrected, but otherwise you
can forget about them. Please only use 'Histo Fix' if you don't plan to sharpen the photo, because sharpening
automatically removes the histogram gaps. However, this feature produces a larger JPG file size.
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Saturation

Some photos are seriously oversaturated, undersaturated or need just a small saturation adjustment. For such cases you
can use the Saturation feature from the Extras tab sheet. The "Red/Orange Cast" setting of the Cast Types feature may
eliminate a lot of saturation from photos, but extremely under− or oversaturated photo, you will still have to use the
Saturation slider to get a better result.

Saturation Method

The Sat. Method combo box lets you choose between various methods for adjusting saturation. "Normal" is the standard
way of adjusting saturation, but it may add artifacts at higher Saturation slider values. "Median" usually doesn't do that.
The six last options represent color filters that suppress the saturation of the color they are named after. For example the
"Yellow" option keeps yellow objects from being saturated too much.

Saturation Slider

Positive values of the Saturation slider increase saturation whereas negative values reduce saturation. Dragging the slider
to the outer left position turns the image to B/W. Together with the Sat. Method combo box this is another way to create
B/W variations of your image.

For normal photos saturation increases or decreases between −10 and 10 are sufficient. Beyond −20 and 20 the effect of
the Saturation slider get quite extreme. Such high settings are only recommended for photos that have serious saturation
problems.
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Customer Support

E−mail: support@thepluginsite.com

Web site: http://thepluginsite.com

User Forum: http://www.graphicsgalaxy.com/forums/thepluginsite/viewforum.php?f=26

If ColorWasher produces a dissatisfying result
on a photo, please send us this photo by email.

It will help us to make the next version of ColorWasher even better.
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Spanish: Selenia (MultiLanguage Services)
Portuguese: Fernando Chaves

Many Thanks to the Beta Testers:

Version 2.0:

Kohan Ikin
Steve Upham
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Robert T.

Sonja Shea
Shannon Carnevale
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Lori Davis
Sally Beacham
Barbara Wallis
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To see the photos of the beta testers in ColorWasher,
move the mouse over the preview and press the B key.
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